Risolviamo il crash di “Google Earth has caught signal 11” Fedora 16


Google Earth su Fedora 16 64bit

Ciao a tutti rieccomi qui a scrivere di Google Earth.

Ogni volta che installo una distribuzione mi tengo per ultimi i software proprietari perchè capita spesso che ci possano essere dei problemi per installarli oppure non si avviano per i più svariati motivi e Google Earth è quello che rompe più di tutti, ma a me serve e quindi cerco sempre di trovare la soluzione.

Dopo aver reinstallato Fedora 16 64bit sul mio PC mi sono tenuto per ultima l’installazione di Google Earth, quindi ho seguito una mia precedente guida che a suo tempo aveva funzionato benissimo, che potete trovare qui.

Dopo averlo installato l’ho avviato e per un’attimo è partito lo splash screen poi è sparito e non si è avviato nulla, quindi ho fatto la solita prova avviandolo da terminale per capire quale era il problema segnalato e ho avuto il seguente messaggio:

Google Earth has caught signal 11.

Quindi mi sono messo alla ricerca è ho trovato la soluzione in un gruppo di discussione di Google che parlava di Google Earth.

Quindi qui sotto vi mostro con tutti i passaggi che ho fatto:

Innanzitutto apriamo il terminale e quindi digitiamo nell’ordine i seguenti comandi:

su

cd /opt/google/earth/free

wget http://librarian.launchpad.net/7037027/libGL.so.1

chmod a+x libGL.so.1

In questo modo abbiamo preso i poteri di super utente, siamo entrati nella directory di Google Earth, scaricato la libreria mancante che lo mandava in crash e gli abbiamo dato i giusti attributi.

Testato su Fedora 16 64bit con driver proprietari nVidia, non so se funziona anche su altre distribuzioni.

Buon divertimento 😉

Annunci

10 pensieri su “Risolviamo il crash di “Google Earth has caught signal 11” Fedora 16

  1. Valerio ha detto:

    Io ho risolto installando ( con scheda Nvidia) le librerie
    xorg-x11-drv-nvidia-libs.i686
    con le sue dipendenze.
    Purtroppo Google Earth non è un software nativo a 64bit, e quando si installa il pacchetto non si “porta dietro” tutte le dipendenze a 32bit.

    Per schede ATI/AMD credo che vada installato il corrispondente:
    xorg-x11-drv-catalyst-libs.i686

    Mi piace

    • Come scrive Valerio si risolve anche installando questo pacchetto yum install xorg-x11-drv-nvidia-libs.i686 per le schede nVididia o questo xorg-x11-drv-catalyst-libs.i686 per le schede ATI. Oppure cerca quello dei driver video che hai installato l’importante che finiscano con .i686.
      Buon divertimento 😉

      Mi piace

  2. Leonardo ha detto:

    Non mi è mai capitato questo tipo di errore fino a quando non mi sono deciso a esplorare la Luna invece che la Terra. Quando vado a ingrandire, il programma si chiude improvvisamente. Ho eseguito la tua procedura, ma non ha funzionato.
    (Ubuntu Mate 16.10)

    Mi piace

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...